Back to overview

Investigating the SSL certificate expiry error on mail.obrienmedia.co.uk

Apr 08 at 01:43pm BST
Affected services
mail.obrienmedia.co.uk - Customer Email Hosting Frontend

Resolved
Apr 08 at 01:43pm BST

We have forced a renewal of the SSL certificate for mail.obrienmedia.co.uk and errors should now have cleared.

We are currently investigating the SSL certificate expiry error on mail.obrienmedia.co.uk. Service remains usable, the error message can be bypassed by selecting the relevant "accept" option on your email client app.