Back to overview
Degraded

Delays to incoming emails to our team

Dec 13 at 04:05pm GMT
Affected services
clientconnect.obrienmedia.co.uk

Resolved
Dec 15 at 12:16pm GMT

The issues have now been fully resolved by Brevo and normal service for inbound emails to our teams has resumed.

Updated
Dec 13 at 09:31pm GMT

The cause of the issue resulting in delays to delivery of emails to our team is still being investigated by our service partner Brevo, we are actively engaging with Brevo to ensure a speedy resolution. For any urgent issues please call the team on 01793 239239 (voicemail is available out of hours and during busy periods)

Created
Dec 13 at 04:05pm GMT

We are aware of an issue with our service provider, Brevo, that is causing a delay to emails sent to our team.

Brevo has applied a fix and we anticipate a full resolution shortly.